Welcome to the
Telkom Community

Get involved. Problem solved.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
LT1
New Member
Posts: 2
Accepted Solution

Bad service LTE

I have ordered a LTE deal online and received my modem today. After unpacking and reading how to set it up realised that I do not have a sim card. It is impossible to get hold of anyone on the number 10213, after trying several times never got through to any one! How and where do I get a sim card?? Good deal if you cannot use the modem......

Established Member
Posts: 13

Re: Bad service LTE

Hi

 

Yes, their Sales line is really not effective. The SIM should have come with the modem etc. I suggest going in to TM store, and hope they dont turn you away because they are really unsopportive to customers who make online sales. There's this idiotic notion among all service providers, "if you didnt use this sales channel, then dont ask us for support"

Maybe the sim will be delivered separately?

 

New Member
Posts: 3

Re: Bad service LTE

You are lucky you even got the modem.

 

I have been waiting a month with still no delivery and no answer from Telkom.

 

I have given up and will just refuse delivery when it arrives and cancel the contract. I will be 100 years old before it arrives by the looks of it.

 

New Member
Posts: 3

Re: Bad service LTE

You are lucky you even got the modem.

 

I have been waiting a month with still no delivery and no answer from Telkom.

 

I have given up and will just refuse delivery when it arrives and cancel the contract. I will be 100 years old before it arrives by the looks of it.

LT1
New Member
Posts: 2

Re: Bad service LTE

Totally agree! Very poor speed! Nothing like what is advertised.
MNC
New Member
Posts: 1

Re: Bad service LTE

I've got an issue as well. LTE Internet download speed went from about 40Mb/s to 0.8Mb/s in the last 4 days. I've had LTE for the last 2 years, and this is the first time it's been this bad for this long. Reset the router, nothing. Flushed the DNS and renewed it, nothing. It must be the network. I've been in touch with Telkom through Twitter, with no avail. I'm quite disappointed in Telkom right now. I've got like 80gb data left that I'm paying for, but can't use!

 

New Member
Posts: 1

IRe: Bad service LTE

Me too. I'm being throttled for some reason.

Member
Posts: 2

Re: Bad service LTE

I have had no connectivity between 29/11 and 23/12 - and then very intermittent connectivity - no feedback from telkom or responses to queries. My fault has not been attended to and when asking for a credit i was ignored like a stop street.

After telling everyone how happy i have been with Telkom for over 2 years I am now sitting with this mess that is just not being resolved at All

About This Post
  • 7 replies
  • 3551 views
  • 1 kudo
  • 6 Contributors