Welcome to the
Telkom Community

Get involved. Problem solved.
Showing results for 
Search instead for 
Do you mean 
Reply
Highlighted
Member
Posts: 1

Can't connect to Telkom/MTN 3G Roaming issues

Hi there. I understand Telkom piggy backs of MTN. I have asked a few friends who have iphones and they say it will not connect to the mtn network when roaming outside Telkom signal areas. It is true for my device too (iPhone 6s) does anyone ahve a solutioin for me? 

Valued Contributor
Posts: 847

Re: Can't connect to Telkom/MTN 3G Roaming issues

Hi @RyanBrunyee

 

I don’t use Telkom mobile but have seen others suggest IOS fixes to roam Telkom > MTN  :- 

 

If the sim works in range of Telkom tower LTE and your iPhone’s locked on 4g/LTE only ,  try changing to 3G , check the APN settings are correct ( Telkom PDF link below - scroll to IOS settings from p.13 ),  turn on roaming, then reboot the phone.

 

https://www.telkom.co.za/today/media/downloads/TelkomInternet_APN_Device_Settings_guide.pdf

 

Just remember to turn roaming off if you’re travelling outside SA .

 

If none of this works you might need to change the sim at a store, but first try a chat with Telkom support or call them on 081180 .

Chat to an Agent 

 

Hope this helps.

J1
New Contributor
Posts: 65

Re: Can't connect to Telkom/MTN 3G Roaming issues

I don't have a problem connecting to MTN. In fact we have a new Telkom presence in Lephalale and I have quite often had to select MTN manually when the Telkom service connects but does not work.

 

I am not familiar with Iphone but Android has a Telkom App called TELKOMSA MENU. You need to select International Roaming then there are two options Via TelkomSA or Via Partners. I think you select Via TelkomSA. You may also need to restart the phone when you change settings.

 

Android also require you to allow Data roaming, there should be a similar setting on Iphone 

 

Let us know if that works otherwise the help line can normally assist with this.

About This Post
  • 2 replies
  • 2666 views
  • 0 kudos
  • 3 Contributors