Welcome to the
Telkom Community

Get involved. Problem solved.
Showing results for 
Search instead for 
Do you mean 
Reply
Member
Posts: 3

Lte broken?

I've had lte for 2 years and this is the 1st time I've been getting such crappy speeds I've been getting 0.2 download and 0.1 upload with 1000 ping its been 6 days and still not fixed all of telkom support is useless
New Member
Posts: 5

Re: Lte broken?

Telkom has become a very terrible isp, ive had had my contract with them since 2016 when i got the huawei b315 router smartbroadband 30gb, for the past 2 weeks the internet connect has been giving me much problems, my router kept changing colours and i kept on losing connection, i factory resetedit about 15 times but nothing happend, i went to the telkom branch in eastgate and they told me it is a sim card probelm, they did a sim swop and said that will fix the problem, it didnt, the problem remained the same. i went back and they checked my account info and did diagnosing of the device but still nothing, they were completely lost, and the only resolution they said was the one i told them about that they thought was the answer, and it was the upgrade i was due for. I have lost alot of data because of this disruption that telkom will never reiburse me for even though they are to blame. so i then upgraded my contract to the huawei b618 router 120 gig special, so now they told me this router is the best in the market but the signal strength is still slow, i use 3g and the time i used 3g on my old router which was the b315 it was relatively fast, but the internet still disconnects and connects. I am really appalled by telko and i called the call centre asking if there was any internet connection or network coverage problem within my area which is Eastbank, Alexandra township, and they said no but i am still experiencing internet problems. I was a mistake upgrading my contract at this point cause there is just negligence and ignorance on telkoms end.

Member
Posts: 3

Re: Lte broken?

Same with me I'm in Durban and some parts of Durban have proper connection and my area doesnt have but it show I have coverage
Member
Posts: 1

Re: Lte broken?

I've been having the same problem in the Carletonville area. Had the B315 router and was working perfect for about a year, by the way the Telkom coverage map shows no LTE in the area, however I had LTE speeds for almost a year. Then one weekend we had heavy thunder and gone is the LTE,3g and anything else you like. I drove around the whole neighborhood with the B315 and battery, doing speed tests all over and with absolute certainty i believe the tower next to spar in Oberholzer, Carletonville is faulty/dead due to the lightning. Speeds around 0.1 to 0.3 mbps. No Lte, No 3g. Like you said the lights on the router is like a christmas tree. Drove to the top part of town - WOW! - 30mbps etc. Tried phoning the 081180, but apparently you cannot log a faulty tower. So i don't know how to resolve my issue, customer support for wireless internet @ telkom Sucks

Highlighted
Member
Posts: 2

Re: Lte broken?

Everywhere that I have been so far as of the end of November does not have LTE signal. The best i've pick up is a weak HSDPA connection. 

New Member
Posts: 3

Re: Lte broken?

Same with me I'm in Durban and some parts of Durban have proper connection and my area doesnt have but it show I have coverage https://downloadluckypatcher.co
New Member
Posts: 1

Re: Lte broken?

Same with me. I pay for 100Gb so I'm not on Uncapped and I know the fair use policy says that you will be throttled after 25Gb on Uncapped. But paying for x amount of data like I am means no throttling. So I complained on there asking if Telkom is perhaps throttling my connection by mistake....hours later, no more problem. Go figure.
About This Post
  • 6 replies
  • 435 views
  • 0 kudos
  • 6 Contributors